Mi universidad me avisa del fallo de seguridad de IE 7.0

Me envían un email desde la universidad de Chicago:

Microsoft has found a high security vulnerability in Internet Explorer 7.0 and all users currently using IE 7.0 are potentially at risk. Microsoft is actively working on a patch to fix this security defect.

Until the vulnerability has been fixed OTS is strongly recommending that all internet users utilize alternate internet browsers, such as Mozilla Firefox (www.firefox.com) or Safari (http://www.apple.com/safari/download/), on both your personal and work computers.

OTS will continue to inform users of any updates that may occur in the “IIT Announcements” channel found on your myiit welcome tab.

Ya sabéis :-D